The vB Geek

Go Back   The vB Geek > vB Geek Products > GeekMart

GeekMart GMart is an integrated shopping cart system for vBulletin.

Advertisement
  Learn how to remove ads

Reply
 
Thread Tools Display Modes
  #1  
Old 09-28-2005, 07:44 PM
The Geek's Avatar
The Geek The Geek is offline
Senior Member
 
Join Date: Aug 2005
Posts: 6,717
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default Maintaining Backward compatability

I'm sitting here plugging away on the next iteration of GeekMart . I know I promised something a couple weeks ago - however I poured all my time into getting GARS where it is so I have a good excuse.

Currently, the only vB3.0x item I have on here is a back ported version of GeekMart . Essentially I am coding it to be vb.3.0x and vb3.5x compatible.

Basically, Its doing my head in and I find myself spending more and more time re-sanitizing variables and putting in workarounds to try and keep the code duo system compliant. I was going to do this until RC stage and then decouple the two so I could optimize both however I just don't know if I can be asked.

Seriously now... How many of you are in need of a vB3.0x GeekMart ? I know there are a few out there, but coding for both is going to take my a lot longer than coding for one system. Hell, that means by the time Gold comes round most people will be on 3.5x anyway.

Just after your feedback.

BTW: Its coming along realllll nicely. A lot more features.

nJoy
Reply With Quote
  #2  
Old 09-28-2005, 08:14 PM
Walim Walim is offline
Junior Member
 
Join Date: Sep 2005
Posts: 20
Default

Hello

I'm waiting Geek Article and Review system That What i'm intersted
Reply With Quote
  #3  
Old 09-28-2005, 08:23 PM
The Geek's Avatar
The Geek The Geek is offline
Senior Member
 
Join Date: Aug 2005
Posts: 6,717
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

Thats in Beta 3 right now. I wouldn't think it will take much longer to get there. However while results come in from beta testing , I'm busying myself with GeekMart
Reply With Quote
  #4  
Old 09-28-2005, 10:20 PM
Fleabag's Avatar
Fleabag Fleabag is offline
Senior Member
 
Join Date: Aug 2005
Posts: 167
Geek Article and Review System License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder 
Default

I'd say drop it Geek. The lack of response is testament to the fact that there isn't demand for the 3.0.x version. In a software world if you want the latest products you have to keep up with everything that goes with it... I think 3.5 is stable enough for anyone to migrate now - personally I don't see any reason not to. Just my 2 cents.
Reply With Quote
  #5  
Old 09-29-2005, 10:14 AM
The Geek's Avatar
The Geek The Geek is offline
Senior Member
 
Join Date: Aug 2005
Posts: 6,717
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder Geek Gazette License Holder 
Default

Yea, think im going to. There was only my 3.0x site I needed compatability for and 1 other user that I know of. Im looking at upgrading within the next week so it seems silly to work so hard at keeping it compatable for both.
Reply With Quote
  #6  
Old 09-29-2005, 05:26 PM
TheComputerGuy TheComputerGuy is offline
Member
 
Join Date: Sep 2005
Location: NC
Posts: 33
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder 
Default

I support the 3.5 vote. 3.5 allows for so much more expandability and complete the Geek Swiss Army Knife!
Reply With Quote
  #7  
Old 09-29-2005, 06:43 PM
KTBleeding KTBleeding is offline
Member
 
Join Date: Aug 2005
Posts: 89
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder 
Default

Honestly, I would say go for the 3.5 development as well. Gold was released recently, and I'm sure everyone will switch him soon enough. Plus, having a hack like this only available for 3.5 will force people to upgrade to 3.5, which is a good thing.

I was nervous to upgrade at first, but I can't wait until I get my 3.5 skin ready for launch. I don't want to work on 3.0.X anymore.
Reply With Quote
  #8  
Old 09-29-2005, 10:52 PM
TheComputerGuy TheComputerGuy is offline
Member
 
Join Date: Sep 2005
Location: NC
Posts: 33
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder Geek Advertising Banner License Holder 
Default

I agree KT. 3.5 is so much easier on the Admin
Reply With Quote
  #9  
Old 10-01-2005, 05:03 AM
sketch42 sketch42 is offline
Member
 
Join Date: Aug 2005
Posts: 68
GeekMart License Holder 
Default

i dunno if im the only one waiting for this on 3.0.x but i can not upgrade to 3.5 as i have many custom hacks {hacks that i have paid to people to write } on my site, now im all for coding for 3.5 but if the original intention was to do for both than please do.. release the 3.5 first if you feel that its easier.. but please dont drop the 3.0.x
personally i dont care if the 3.0.x has crazy bells and whistles i would be satisfied with just the basics but in the end you need to do whats best for you and your sanity so.. really its up to you
Reply With Quote
  #10  
Old 10-01-2005, 05:02 PM
Sony Sony is offline
Junior Member
 
Join Date: Sep 2005
Posts: 4
Geek Article and Review System License Holder GeekMart License Holder Geek Auto-Linker Pro License Holder 
Default

I would go 3.5+ and concentrate on that, most people will eventually upgrade like it happen with 3.x
One version will keep the code cleaner and speed up your work and testing of betas
__________________
Best Regards,

Sony
www.vbstyles.com
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
compatability... toibs GeekMart 1 01-09-2006 08:55 AM


All times are GMT. The time now is 11:03 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.